No estás registrado (Registrarse)

Vanilla 1.1.10 es un producto de Lussumo. Para más información: Documentación, Soporte.

    •  
      CommentAuthorturminator
    • CommentTimeAug 21st 2019
     # 1
    Buenos días,

    Curiosamente me he encontrado con un dominio de la misma temática que el mío que ha caducado por lo que no he dudado en comprarlo. Era un dominio con numerosos enlaces y backlinks y lo he pillado a través de GoDaddy y desde allí he hecho una redirección 301 permanente del dominio adquirido al mío.

    Cual es el problema...que ahora todas las URLs del antiguo dominio los redirige a la raíz de mi dominio pero con la misma URL que había antes. Como no puedo crear todas las url en mi dominio de siempre entonces me aparece la página de error 404. He ptratado de realizar diferentes configuraciones en .htaccess pero no consigo dar con el clavo.

    Creo que lo mejor sería mandar todas estas URLs a la página principal de mi sitio, así evitar el error 404 y hacer que los usuarios visiten mi página web desde la portada, aunque de esta forma no discriminaria entre errores 404 en la propia estructura de mi web y los 404 que vienen del exterior.

    Alguien puede recomendarme algo?

    Muchas gracias,Mis Dominios | Como hacer nudos | |
    •  
      CommentAuthorprekfawkz
    • CommentTimeAug 21st 2019 editado
     # 2
    Prueba esto
    Options +FollowSymLinks -MultiViews
    RewriteEngine on

    RewriteCond %{HTTP_HOST} ^(www\.)?capturado\.com$ [NC]
    RewriteRule ^ http://www.principal.com/ [R=301,L]
    Dominios de tres letras | Free Subdomain
    •  
      CommentAuthorturminator
    • CommentTimeAug 21st 2019
     # 3
    Gracias prekfawkz,

    Acabo de probar lo que me has comentado y sigue respondiendo del mismo modo.

    Options +FollowSymLinks -MultiViews
    RewriteEngine on

    RewriteCond %{HTTP_HOST} ^(www\.)?diccionariomedico\.org$ [NC]
    RewriteRule ^ https://www.diccionariomedico.net/ [R=301,L]


    Cuando por ejemplo alguien accede a un URL que estaba enlazada con el dominio caído:

    www.diccionariomedico.org/Glipizide_61.htm

    Me redirige a mi dominio pero con la URL antigua:

    https://www.diccionariomedico.net/Glipizide_61.htm

    con lo que obtengo el error 404, en vez de mandarme a la raíz de mi sitio. Mi idea es que en estos casos el servidor me mandara la raíz de mi dominio: https://www.diccionariomedico.net

    Muchas gracias por tu ayuda,Mis Dominios | Como hacer nudos | |
    •  
      CommentAuthorCorso
    • CommentTimeAug 21st 2019
     # 4
    A ver si esto:

    RewriteEngine On
    RewriteRule ^(.*)$ https://www.diccionariomedico.net/ [R=301]
    :: el roce hace el dominio ::
    •  
      CommentAuthorturminator
    • CommentTimeAug 21st 2019
     # 5
    Gracias Corso,

    He probado tu código yme sale el siguiente error en todas las páginas pese a borrar las cookies de todos los navegadores.

    Esta página no funciona La página www.diccionariomedico.net te ha redirigido demasiadas veces.
    Borrar las cookies.
    ERR_TOO_MANY_REDIRECTS


    No sé como solucionarlo:ildivo:Mis Dominios | Como hacer nudos | |
    •  
      CommentAuthorprekfawkz
    • CommentTimeAug 22nd 2019 editado
     # 6
    Mismo código en el domain grat.is redireccionando a demene.com:

    http://grat.is/Glipizide_61.htm

    Revisa que esté bien, el código que te proporcioné es correcto.

    El .htaccess supongo que lo tienes en la raiz del dominio...Dominios de tres letras | Free Subdomain
    •  
      CommentAuthorCorso
    • CommentTimeAug 22nd 2019 editado
     # 7
    Algún conflicto con otras redirecciones... Tendría que ver los headers activada la(alguna) redirección. Ahora no funciona. Entendemos que https://www.diccionariomedico.net es tu URL canónica.

    Por si acaso, prueba:

    RewriteEngine On
    RewriteRule ^(.*)$ https://www.diccionariomedico.net/ [R=301,L]
    :: el roce hace el dominio ::
    •  
      CommentAuthorCorso
    • CommentTimeAug 22nd 2019 editado
     # 8
    curl -I diccionariomedico.org/Glipizide_61.htm
    HTTP/1.1 301 Moved Permanently
    Server: nginx/1.12.2
    Date: Thu, 22 Aug 2019 07:59:24 GMT
    Content-Type: text/html; charset=utf-8
    Connection: close
    Location: https://www.diccionariomedico.net/Glipizide_61.htm


    :neutral::: el roce hace el dominio ::
    •  
      CommentAuthorturminator
    • CommentTimeAug 22nd 2019
     # 9
    Posted By: prekfawkzMismo código en el domain grat.is redireccionando a demene.com:

    http://grat.is/Glipizide_61.htm

    Revisa que esté bien, el código que te proporcioné es correcto.

    El .htaccess supongo que lo tienes en la raiz del dominio...Dominios de tres letras|Free Subdomain


    Buenos días,

    He vuelto a escribir tu código y sigue realizandome el mismo comportamiento.

    La URL:

    www.diccionariomedico.org/Glipizide_61.htm

    Me la redireccio a mi extensión pero manteniendo la mirma URL final:

    https://www.diccionariomedico.net/Glipizide_61.htmMis Dominios | Como hacer nudos | |
    •  
      CommentAuthorCorso
    • CommentTimeAug 22nd 2019
     # 10
    curl -I grat.is/Glipizide_61.htm
    HTTP/1.1 301 Moved Permanently
    Connection: Keep-Alive
    Date: Thu, 22 Aug 2019 08:02:02 GMT
    Location: http://www.demene.com/
    Strict-Transport-Security: max-age=63072000; includeSubDomains
    X-Frame-Options: SAMEORIGIN
    X-Content-Type-Options: nosniff


    Nada de WPshit por aquí :first::: el roce hace el dominio ::
    •  
      CommentAuthorturminator
    • CommentTimeAug 22nd 2019
     # 11
    Posted By: Corsocurl -I diccionariomedico.org/Glipizide_61.htm
    HTTP/1.1 301 Moved Permanently
    Server: nginx/1.12.2
    Date: Thu, 22 Aug 2019 07:59:24 GMT
    Content-Type: text/html; charset=utf-8
    Connection: close
    Location: https://www.diccionariomedico.net/Glipizide_61.htm


    :neutral::: el roce hace el dominio ::


    Me has pillado justo modificando el .htaccess. Según esto el .htaccess lo tengo bien colocando pero sigue haciendo el mismo comportamiento.:que:Mis Dominios | Como hacer nudos | |
    •  
      CommentAuthorprekfawkz
    • CommentTimeAug 22nd 2019
     # 12
    Va a ser por el nginx...Dominios de tres letras | Free Subdomain
    •  
      CommentAuthorturminator
    • CommentTimeAug 22nd 2019
     # 13
    Mejor pruebo de cambiar Apache entonces...gracias!Mis Dominios | Como hacer nudos | |
    •  
      CommentAuthorprekfawkz
    • CommentTimeAug 22nd 2019 editado
     # 14
    O convertirlo
    Yo es que no he llegado a usar nginx, me pierdoDominios de tres letras | Free Subdomain
    •  
      CommentAuthorCorso
    • CommentTimeAug 22nd 2019
     # 15
    Posted By: prekfawkzVa a ser por el nginx...


    Estoy :noloveo:.:: el roce hace el dominio ::
    •  
      CommentAuthorprekfawkz
    • CommentTimeAug 22nd 2019 editado
     # 16
    Posted By: Corso
    Posted By: prekfawkzVa a ser por el nginx...


    Estoy :noloveo:.:: el roce hace el dominio ::

    Y yo :dumb: por no haber mirao las cabeceras, cosa que tú sí :cataa:
    La unión hace la fuerza :matu:Dominios de tres letras | Free Subdomain
    •  
      CommentAuthorCorso
    • CommentTimeAug 22nd 2019 editado
     # 17
    Editar /etc/nginx/sites-available/diccionariomedico.org (o el archivo general de configuración, no estoy seguro)

    Añadir:

    server {
    listen 80;
    listen 443 ssl;
    server_name www.diccionariomedico.org diccionariomedico.org;
    return 301 $scheme://www.diccionariomedico.net;
    }


    Según https://www.nginx.com/blog/creating-nginx-rewrite-rules/:: el roce hace el dominio ::